No announcement yet.

Unable to open 'Template File' file within Exporter Pro

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to open 'Template File' file within Exporter Pro


    I seem to be having issues when trying to export objects. I do choose to Run as Administrator yet sometimes this error occurs and I can't get any exported objects. The complete error is:

    Unable to open 'Template File' file c:\users\tcentofanti\AppData\Roaming\SystemTools\E xporterPro\File Templates.cfg. Check access permissions to this file onthe account being used. The system cannot find the file specified.

    I get this when trying to use an existing template as well as trying to create a new template. Is there a place I can get the required file(s) from if they do not exist?

    Thanks, Tracki

  • #2
    Let me know if you are running Hyena to get access to EP, or using EP directly, and also what version of Hyena/EP you are using.

    A couple of releases ago we made changes to where EP looks for these files. When you install Hyena, the .cfg files get installed to the program installation directory. However, Windows Vista and later operating systems largely prevent users from writing to the program's own installation directory even if you are running as an admin, and even then, we can't expect every user to 'run as admin'. So this was causing a lot of support issues. Microsoft requirements for logo usage also require that applications not write to files in the installation directory and the only 'default' space that is predictably there for all users is the profile directory, which is what you have for the path above.

    What is supposed to happen, is that when you run Hyena, it tries to create the \ExporterPro directory, and if it creates this directory, then it copies the .cfg files from the installation directory. If the directory already exists, then it assumes the copy was already done, as we don't want to overwrite the files as they are meant to be updated by the user.

    If you look in the path listed above, see if you see the directory itself ...\SystemTools\ExporterPro, and if so, if the .cfg files are located there. Windows may be giving this same error if the directory does not exist, or if the file isn't there (same error).

    Let me know what you find so that we can determine if there is a better way to do this. Thanks
    Kevin Stanush
    SystemTools Software Inc.


    • #3
      "Thanks for the information. Not all of the CFG files were in the users directory so I copied them from the installation directory and my problem is resolved."

      Thanks for the info. That is curious, as all of the files are copied in the same routine. Its possible that some may have already been there, but if the directory is created, then all 5 files are copied.

      Glad at least it was something easy to find. Thanks again for reporting this.
      Kevin Stanush
      SystemTools Software Inc.