Announcement

Collapse
No announcement yet.

Exporting WMI Info

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exporting WMI Info

    I'm trying to use Exporter Pro to export WMI information on every server in my forest. For two of the three child domains I have no problems getting the information. On many of the servers in the third domain, however, the WMI calls fail with the error "Win32 HRESULT 0x800706BA=The RPC Service is Unavailable" I know connectivity is working because I can dump other data from these servers, just not the WMI data. What protocol does WMI use and what would cause its failure?

    I've already tried changing the type of ping to use and changing the settings in Hyena not to use DNS computer paths. This got me around having pings fail, but didn't get me the WMI data.

    [This message has been edited by CHooper (edited 04-07-2006).]

  • #2
    Re: Exporting WMI Info

    This might be the Windows Firewall blocking you. Go to the WMI forum on this board and then click Search and type in RPC. There's some things you can try in those posts.

    Comment


    • #3
      Re: Exporting WMI Info

      Thanks. I'll give that a try.

      Comment


      • #4
        Re: Exporting WMI Info

        The topic under WMI was for workstations. I'm trying to reach a mix of Win2k and Win2k3 servers.

        Comment


        • #5
          Re: Exporting WMI Info

          After some more testing, I found that if I log into a server in the same part of the world as the servers from whom I can't get WMI data, I can get the data from some of them. Exporter Pro reports that the RPC services is unavailable. I know this is incorrect as on all of them, I can see services, bring up properties, etc. I've tried changing the export properties to use NetBIOS, to get the computer names from AD, not to use ping, and other permutations. Nothing seems to help get the WMI information from all of the computers.

          What's different about WMI?

          Comment


          • #6
            Re: Exporting WMI Info

            WMI uses DCOM, so that is where the problem might be. There is a utility that you can run, dcomcnfg, that might show some clue as to why WMI access fails on these remote computers. dcomcnfg has to be run locally on each computer.

            You should verify that WMI does not work outside of Hyena as well, by using either a VB script or CIMStudio from MIcrosoft.
            Kevin Stanush
            SystemTools Software Inc.

            Comment

            Working...
            X