Announcement

Collapse
No announcement yet.

Unable to open registry software key

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to open registry software key

    In evaluating Hyena's export feature, I am attempting to create a list of all installed applications across my domain. I have approximately 30 machines of which 29 work fine and one does not. The error reported in the configuration window is "...Unable to open registry software key on [PC name]. Access is denied." RPC and remote registry is running. I also verified that all of the permissions on each registry key of the PC appear to be kosher [default at the least]. Can anyone tell me anything else I can check? Thanks!

  • #2
    Re: Unable to open registry software key

    Does it by chance have the Windows Firewall running under Control Panel?

    Comment


    • #3
      Re: Unable to open registry software key

      I wasn't 100% certain, but I just verified that the ICS/Windows Firewall Service is disabled.

      Comment


      • #4
        Re: Unable to open registry software key

        If you are getting an access denied error, then the Firewall is not involved, because if it was, you would be getting either a host not found or RPC failure error.

        Use regedit or regedt32 to see if you get the same error. Its probably the security settings perhaps due to the computer not being a domain member or the domain admins group not being a local admin group member or something. YOu may have to check it locally to see the security settings and fix them.
        Kevin Stanush
        SystemTools Software Inc.

        Comment


        • #5
          Re: Unable to open registry software key

          In Hyena or regedt32.exe, can you navigate to each of the keys? Look at the list of keys in the Installed Software Applications template from Exporter Pro.

          Comment


          • #6
            Re: Unable to open registry software key

            The PC is definitely a proper object of the domain as well as having the domain admins (me) a member of the local administrators group on the PC. However, if I attempt to view the key remotely via registery editor, I do get a permissions denied error even though the everyone group has read access. I then attempted to add everyone as having full access. I still could not access the key. I have a feeling it has something to do with the local security policy for the machine and where you define the paths of the registry which are remotely accessible. currently this is what is listed for this setting:

            Software
            System\CurrentControlSet\Control\ProductOptions
            System\CurrentControlSet\Control\Print\Printers
            System\CurrentControlSet\Control\Server Applications
            System\CurrentControlSet\Services\Eventlog
            Software\Microsoft\OLAP Server
            Software\Microsoft\Windows NT\CurrentVersion
            System\CurrentControlSet\Control\ContentIndex
            System\CurrentControlSet\Control\Terminal Server
            System\CurrentControlSet\Control\Terminal Server\UserConfig
            System\CurrentControlSet\Control\Terminal Server\DefaultUserConfiguration

            Any thoughts?

            Comment


            • #7
              Re: Unable to open registry software key

              Not sure if you were able to resolve the problem but this is the solution. I had the same problem with other applications(UpdateExpert) that were unable to communicate with HKLM etc.... I believe the issue is with 2003 SP1 servers and is related to the access to the following key below.

              HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\SecurePipeServers\winreg

              View the permissions for "winreg" then added
              the "Local Service" account with READ access to winreg. Restart the remote registry service after making the change.

              Comment


              • #8
                Re: Unable to open registry software key

                That worked great! Thank YOU!!!

                Comment

                Working...
                X