Announcement

Collapse
No announcement yet.

Slow response time accessing user properties

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Frank Rizzo
    replied
    Re: Slow response time accessing user properties

    Thanks for your help on this one, I think we've got to the bottom of it now. It is an issue with a particular distribution group the user is a member of. This distribution group exists in another domain in our forest and for some reason Hyena & our mail signature program are having trouble with this group. When I expand the groups for the user in Hyena, it takes an age and when it finally comes up this group is missing. I can see it in the AD attributes however.

    Thanks again for your help, now we've pinpointed the problem we can follow up with the owners of the dist. group.

    Leave a comment:


  • kstanush
    replied
    Re: Slow response time accessing user properties

    If you expand the users in the left window of Hyena, and then find this particular user, click on the + sign next to the user, then expand the groups in the left window, is there a long delay ? Or, if you double-click on the Groups object under the user to display the group member information in the right window, does it also take a long time ?

    I'm running out of ideas, as the Manage Directory Attributes function when viewing all attributes would load/read everything from AD, the RAS/Terminal junk can be a problem as it does not get interpreted by AD directly, and the only thing left is the group information.

    The other thing you could do as a test is to copy the account. This would copy all of the data, including the groups. This would be just for a test to see if the copied account is also 'slow'.

    Leave a comment:


  • Frank Rizzo
    replied
    Re: Slow response time accessing user properties

    I tried disabling the RAS & terminal services and restarting Hyena but there was no difference. The user is a member of 69 groups (distribution lists & security groups combined).

    I don't think this is an issue with Hyena as we have another application that runs in our logon script to create an email signature by looking up AD details and that has long delays with this account. I was hoping that someone with knowledge of how Hyena integrates with AD maybe able to point me in the right direction with regards to troublshooting the problem with this account.

    Leave a comment:


  • kstanush
    replied
    Re: Slow response time accessing user properties

    When you look at the user properties, I assume you are seeing a Dialin and Terminal tab. If you see either, go into Tools->Settings->User and disable the options to see the RAS and Terminal Server settings. Then, restart Hyena and then try to display the user account.

    Assuming that does not do anything significant, how many groups does this user belong to ?

    Leave a comment:


  • Frank Rizzo
    replied
    Re: Slow response time accessing user properties

    Thanks for your reply.

    I have the problem accessing the user account using the Hyena standard properties. If I use the 'Shell Properties' the information is returned promptly.

    If I choose to 'Query Active Directory' then 'View all directory attributes' for the user there is no delay. Using 'Manage Directory Attributes' also shows no delay when retrieving all user attributes.

    Viewing user information using the NET user command showed no delay either.

    I know the 'delete user account' is an option but I'd like to avoid it if possible as due to the type of user this may well cause quite a few other issues. It may be the only way to go though if I can't resolve it.

    Leave a comment:


  • kstanush
    replied
    Re: Slow response time accessing user properties

    There are an almost infinite number of variables, but first see if you are using the Hyena property pages or the shell pages to view the user properties. I assume you are using the standard Hyena property pages.

    One thing to check would be to use the Manage Directory Attributes function to try to narrow down which attribute might be at fault. Chances are that its an attribute with a lot of data in it. If you retrieve a handful of attributes and its fast, then select another range of attributes and its a lot slower, you would know that you have included the problem and can narrow it down.

    You could also try running the Net User command on the server to see if its slow too, maybe a console output will show a pause where its hanging.

    The other thing you could do is to just delete the user account and create a new one.

    Leave a comment:


  • Frank Rizzo
    started a topic Slow response time accessing user properties

    Slow response time accessing user properties

    Hi there

    We're having a problem with a particular user account where we get a very long delay (10-15 minutes) when double clicking on the user account to access user properties. So far it only seems to be one user account and I don't think it's a Hyena specific problem as another application we use that carries out AD queries is experiencing the same long delay accessing this account.

    Has anyone experienced anything like this and can point me in the right direction to troubleshoot this issue? I don't have the delay if I access the user properties via ADUC.

    Cheers
Working...
X