Announcement

Collapse
No announcement yet.

Query AD for computers no longer working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Query AD for computers no longer working

    Hi!

    I recently upgraded to 8.6 and have since had a problem doing a query for computers in a OU.

    This is my query: http://dl.dropbox.com/u/4328844/14-1...2009-41-56.jpg

    The OU have some subfolders where I before could do a query on the parent folder and then get a list of all the computers in the subfolders.

    How can I this in 8.6?

  • #2
    Re: Query AD for computers no longer working

    When you click on Containers/OUs, you'll see a toolbar appear at the bottom of Hyena. Click the first icon to Traverse Containers. When you run your query that will cause it to show subfolders as well.

    Comment


    • #3
      Re: Query AD for computers no longer working

      I've tried using the folder with the green arrow icon when I've selected the OU with the subfolders but it doesn't change anything I'm affraid.

      Even if I choose the "All computers" query that's "built-in" in Hyena I don't get any computers shown.

      Like this: http://dl.dropbox.com/u/4328844/14-1...2014-09-45.jpg

      It doesn't find anything.

      Comment


      • #4
        Re: Query AD for computers no longer working

        Go back to File->Manage Object View->AD Queries, and double-click on one of the queries you are running. There's a checkbox at the bottom to Include subcontainers.

        Make sure that is checked, and if it already is, let us know if you have anything in the LDAP Search Filter box.

        Comment


        • #5
          Re: Query AD for computers no longer working

          The checkbox is checked. I have this LDAP: (objectclass=computer)

          Comment


          • #6
            Re: Query AD for computers no longer working

            What happens if you just double-click on that shortcut rather than running one of your queries? Do you see computers that way?

            From what you've sent everything looks good, so there's something missing. Possibly permissions keeping you from seeing computers in those OUs?

            But see if you can just navigate through and see computers in that location at all to try and narrow down whether the problem is with your queries or something else.

            Comment


            • #7
              Re: Query AD for computers no longer working

              If I double click the OU I get everything listed in the right side. Computers, printers and all the OU subfolders.

              It's like the query doesn't do anything at all. I'll try to install a older version of Hyena and see if I can see any difference.

              Comment


              • #8
                Re: Query AD for computers no longer working

                OK, now I've tried with version 8.1 and the latest 8.8. I'm trying the "out-of-the-box" All Disabled Users and All Contacts AD queries.

                If I use the All Disabled Users it will find all the disabled users located in different subfolders.

                If I use the All Contacts the search returns nothing. And the it's same OU I run the query one.

                Hmm what could this be?

                Comment


                • #9
                  Re: Query AD for computers no longer working

                  I assume you had the same results with 8.1? Try using the OU Filtering Toolbar at the bottom of Hyena as a quick test. You'll select Traverse Containers, and Show Contacts.

                  Then double-click on the OU you are using and see if it displays the contacts.

                  Comment


                  • #10
                    Re: Query AD for computers no longer working

                    Yeah the same with 8.1.

                    If I do the traverse and show contacts I get all the users so that works.

                    But if I do the same with computers it doesn't work.

                    I've tested with 8.8

                    Comment


                    • #11
                      Re: Query AD for computers no longer working

                      At this point we need to be able to see everything from start to finish, so send screenshots to [email protected]. As many different angles as you can provide would be best.

                      Comment


                      • #12
                        Re: Query AD for computers no longer working

                        OK, I've sent an email now. Thanks.

                        Comment

                        Working...
                        X