Announcement

Collapse
No announcement yet.

OS not showing up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OS not showing up

    I am using Hyena 5.2 against an AD. Several of the systems are not listing what OS they have. Is there a way to update trigger this?

  • #2
    Re: OS not showing up

    Where are you viewing this information, and what does it show?

    Comment


    • #3
      Re: OS not showing up

      Both under tabular view computer detailed and also under the computer properties.

      Comment


      • #4
        Re: OS not showing up

        Send a screen shot showing this, and the type of the computers that are not showing properly to [email protected].

        Comment


        • #5
          Re: OS not showing up

          We've got the same issue -- only Windows NT/2000/XP based machines show up. The "OS" and "Version" fields (which we map to the LDAP "operatingsystem" and "operatingsystemversion" fields) are blank for Windows 9x based machine (which, thankfully, we don't have that many of).

          I'm fine with these being blank -- but why doesn't Hyena allow me to EDIT them if they are? I'd like to add the information to AD manually.

          I guess I can do it with an LDAP tool.

          As an aside -- when is WMI information going to be available? That would be outstanding!

          We just bought a 5-pack. I'm very happy with the tool and even happier with the support (for example, last week I tried to contact four different vendors about various things and only SystemTools even bothered to reply -- and they actually had someone who KNEW something answer the questions).

          Comment


          • #6
            Re: OS not showing up

            AD seems to update these fields automatically (not sure when or how) and it may be that either AD does not know what a Windows 9x machine is, or Windows 9x does not know about AD so these attributes probably won't update.

            I was surprised however that AD seems to treat these fields as read/write. Here is how to update it manually in Hyena.

            - Click the first toolbar button (Object Manager).
            - Click Custom
            - Select Workstation as the Object Type
            - Select New... and type in OperatingSystem for the directory name, leave other fields defaulted
            - Repeat process for operatingsystemversion, it too is a string value, so leave all fields defaulted

            Close Object Manager, then look at the properties for a computer, click on the Custom tab to see/modify custom directory attributes.

            I thought that these fields were readonly. However, I don't know if you change them if Windows may change them to something else at a later time.

            We still hope to get the beta release of Hyena v6.0 out by the end of the month. Full WMI functionality, however, will only be available for Enterprise licenses with maintenance through June 1, 2004. Hope you are one of them !. We are very excited about the new features that WMI makes available.

            To join the beta list, send a blank email to [email protected]

            Thanks for your support.
            Kevin Stanush
            SystemTools Software Inc.

            Comment


            • #7
              Re: OS not showing up

              Thanks -- that's great. We'll see if AD erases/updates these (for the machines that are currently blank).

              Sad that WMI is for enterprise only...perhaps we'll upgrade....

              Comment


              • #8
                Re: OS not showing up

                Even for Standard Edition users, you will have access to the WMI Win32_Process class, so that you can see how the WMI functionality works and have access to the create/terminate remote process through WMI.
                Kevin Stanush
                SystemTools Software Inc.

                Comment

                Working...
                X