Announcement

Collapse
No announcement yet.

deletion of Exchange 5.5 mailboxes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • deletion of Exchange 5.5 mailboxes

    It has come to our attention that if an Exchange 5.5 mailbox is deleted using the “Enable Hyena’s Custom Exchange Integrations Options” via Hyena, the mailbox resources are orphaned. See MS KB article 284199.
    http://support.microsoft.com/default...99&Product=ech

    Just not sure if SystemTools was aware of this issue?

  • #2
    Re: deletion of Exchange 5.5 mailboxes

    If you are seeing this problem, then its either a bug in Exchange or something in your configuration that is causing it. Hyena uses the DAPI interface when managing Exchange, including deleting mailboxes, which this KB article indicates is the right mechanism to use. Try deleting an account, then wait a few hours to see if the resources are then freed. If that does not do it, try the consistency checker to see what it finds (hope that I am remembering that right).

    If you can reproduce the problem, and want to open a case with Microsoft, let us know as we have some time to use up.
    Kevin Stanush
    SystemTools Software Inc.

    Comment


    • #3
      Re: deletion of Exchange 5.5 mailboxes

      Thanks Kevin. We recently found approx 500 orphaned mailbox resources dating back from about 2 years ago. Our account operators have been using Hyena exclusively for that period of time to delete accounts and the Exchange 5.5 mailboxes. The problem we found was that the resources were not being freed up and we had to use the consistency checker to clean them up. We are starting a project to migrate to Exchange 2003 and so we won't persue this problem now. It was more of an FYI, curious that this was happening...

      Comment


      • #4
        Re: deletion of Exchange 5.5 mailboxes

        The only reason that I remembered the consistency checker thing was that this topic came up a while back and we had to contact Microsoft and it turned out to be a bug in Exchange. When you delete a mailbox using the DAPIWrite API function, the request to cleanup the Exchange resources is sort of queued up, but the bug was that this mechanism didn't work right. If you can duplicate the problem and have the latest service packs installed, let me know if you want to open a case to see what is up.

        Thanks
        Kevin Stanush
        SystemTools Software Inc.

        Comment

        Working...
        X