No announcement yet.

Problems with Exchange 2K integration

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Exchange 2K integration

    I've configured Hyena with some home directory templates and Exchange 2000 settings, using a shared .ini file, and so far I've had no luck in having Hyena create the mailbox for me. I also find that the home directory share/folder creation works about half of the time. In my last test I didn't get either the share/folder or Exchange mailbox created.

    I am logged in with a Domain Admin account and we are running Exchange 2000.

    Here are the 3 error messages I'm getting (minus any specific servernames etc):

    "Unable to lookup account on server \\servername for account Domain Admins. The RPC Server is unavailable."

    "Unable to set security descriptor for user username."

    "Unable to create mailbox for user LDAP://domain/CN=username\,Firstname,OU=domain,OU=Accounts,DC=do main,DC=ca'. The server is not operational."

    Does anyone have any info to help with this one?

    BTW, I used RPCPING to test the RPC connection between the workstation I'm using and the Exchange server and also between my workstation and a local domain controller and RPCPING worked fine.


  • #2
    Re: Problems with Exchange 2K integration

    I should mention that the situation I'm talking about is when I right-click All Users and then select New.

    The new user gets created and about half the time or slightly better the home directory and share gets created according to my home directory template but the exchange mailbox does not get created - although the exchange 2000 settings are configured.

    I just right-clicked (using Hyena) on one of the users I created - for which a mailbox was not created - and selected Exchange Functions - Create Mailbox and it worked fine. So..I wonder why it works when modifying an existing user but not when creating a new user.


    • #3
      Re: Problems with Exchange 2K integration

      In your error #3 (server is not operational...), is the domain portion right after the LDAP:// a netbios name, or a DNS-style name ?

      The other errors that you are getting is the server name in the error always the same server ? And is it the same as the server in the error on item #3 ?

      What version of Hyena are you using ?
      Kevin Stanush
      SystemTools Software Inc.


      • #4
        Re: Problems with Exchange 2K integration

        We're using v5.2B Enterprise.

        After rebooting my own workstation and doing a quick test the first two errors went away - at least on my one test. However, the third error is still happening.

        The name that comes after LDAP:// looks like a netbios name - that is, there is no .CA at the end.

        Hope this helps.


        • #5
          Re: Problems with Exchange 2K integration

          Go to File->Manage Object View, click on your domain, and change the ADSI Path to LDAP:// format.

          Click Update and then OK and let us know if that fixes it.


          • #6
            Re: Problems with Exchange 2K integration

            That did it. Thanks very much!


            • #7
              Re: Problems with Exchange 2K integration

              I'm setting up a workstation to work with our new 2003 exchange server and am having simmilar problems. I'm changing the following LDAP://VO-PHX-AD01.VALUEOPTIONS.FHC1.NET
              with LDAP://VALUEOPTIONS.FHC1.NET.CA
              is this correct? What does this exactly do by changing this, if it's easy to explain.


              • #8
                Re: Problems with Exchange 2K integration

                We can't really say which is correct because we don't know how your Windows 2003/DNS/Active Directory is configured. But in general, you seem to have the right path format.

                The latest release of Hyena has a browse button at the end of the LDAP path input field. You should use it if in doubt.
                Kevin Stanush
                SystemTools Software Inc.


                • #9
                  Re: Problems with Exchange 2K integration

                  I understand, I had to take CA off and it was back to my original settings. I didn't notice the browse button before, very nice.