Announcement

Collapse
No announcement yet.

group name %G% does not work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • group name %G% does not work

    I have my Members of 'grpName' list on the right hand side of the Hyena window and pressing Ctrl+F2 (my tool=cscript scriptname.vbs %G% %C1%) does NOT give my group name, member name

    what am I doing wrong?

  • #2
    Re: group name %G% does not work

    There is no variable for the group name. What you'll have to do is use the Column number (%C1%, %C2%, etc) from the right window that contains the information you need.

    Comment


    • #3
      Re: group name %G% does not work

      QUOTE from hyena help User-defined Tools
      %G% - Group. This option is only valid when vieweing members of local or global group; it will be replaced with the name of the selected members' group name.
      UNQUOTE

      is this really not working? - sad.
      is there any other way to get the user name and the active group name to a CustomTool?

      Comment


      • #4
        Re: group name %G% does not work

        The %G% symbol was only valid for Windows NT groups, so the documentation is out-of-date. We'll review this for the next release to see if we can/should implement it for AD data. But like Chuck said, you can always use the %1, etc. symbols to get out any data. The problem with AD data is the 'name' has multiple meanings and the order of the fields can be changed. If we implement this at all, %G% would return the contents of the samaccountname attribute, since its equivalent to the former NT group name.
        Kevin Stanush
        SystemTools Software Inc.

        Comment


        • #5
          Re: group name %G% does not work

          ok, accepted with NT4 in mind

          what did youy mean with %1?

          is there anywhere a complete list of the "options" parameters that one can use?

          tia

          Comment


          • #6
            Re: group name %G% does not work

            That should have been %C1%, %C2%, etc.

            Comment


            • #7
              Re: group name %G% does not work

              one last question about the parameters.

              %C1,2,3% is alright for the columns - OK

              but what more is there
              %E% = Entry (active item)
              %G% not in use anymore
              %P%, still working?
              anything morefor automation?

              tia

              Comment


              • #8
                Re: group name %G% does not work

                You can see a list of all of the symbols under Configuration and Customization->User-Defined Tools in the help file. And we should get the %G% working in the next release for Active Directory data.
                Kevin Stanush
                SystemTools Software Inc.

                Comment

                Working...
                X