Announcement

Collapse
No announcement yet.

Created registry key doesn't show up on computer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Created registry key doesn't show up on computer

    Hi,

    I'm using Hyena 8.1 and I am creating a registry key with value under HKLM\SOFTWARE\ on a Windows 7 client.
    It looks fine but it doesn't show up on the client (when I look in the local regedit).
    If I create the registry key locally in regedit on the Windows 7 computer it doesn't show up when I look at the computer in Hyena!?!
    Everything works fine if I try to create (or delete) a registry key (or value) under HKLM\SYSTEM or under HKCU.

    I'm so confused.

  • #2
    Re: Created registry key doesn't show up on computer

    Is the computer you have Hyena installed on 32 bit or 64 bit?
    Is the remote computer 32 bit or 64 bit?
    Did you install the 32 bit or 64 bit version of Hyena?

    Comment


    • #3
      Re: Created registry key doesn't show up on computer

      The client I'm trying to change is a Windows 7 is 64-bit
      Hyena is installed in Citrix on a Server 2008 R2 64-bit
      But Hyena is probebly the same 32-bit Hyena we alwas have had.

      Comment


      • #4
        Re: Created registry key doesn't show up on computer

        There is a 32 bit and 64 bit registry, so my theory would be that's the problem. You can try using the 64 bit version of Hyena, or go to Tools->Settings->Advanced and change x64ForceWindowsRegistry to True.

        Comment


        • #5
          Re: Created registry key doesn't show up on computer

          Haven't tried it yet but it seems rational (I cannot do it myself, I have to order the work from our Citrix-group). So if I change it will I still be able to adminitrate clients with Windows XP, 32-bit, like before?

          Comment


          • #6
            Re: Created registry key doesn't show up on computer

            Yes. This setting only affects 32 bit clients viewing 64 bit registry.

            Comment


            • #7
              Re: Created registry key doesn't show up on computer

              Thank you!
              With the 64-bit Hyena it works.

              Comment


              • #8
                Thank you

                Originally posted by cmccullough View Post
                There is a 32 bit and 64 bit registry, so my theory would be that's the problem. You can try using the 64 bit version of Hyena, or go to Tools->Settings->Advanced and change x64ForceWindowsRegistry to True.
                Thanks that setting worked for me, as well.

                Now to try and convince management we need the new version...<sigh>.

                Comment


                • #9
                  I'm glad that helped. Let us know if you need any help with information justifying an upgrade (tell us the version you're on now), and we'll see what we can put together.

                  Comment

                  Working...
                  X