Announcement

Collapse
No announcement yet.

Error E_ADS_OBJECT_UNBOUND when setting password

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error E_ADS_OBJECT_UNBOUND when setting password

    I believe I found a bug in Hyena 7.2.
    When I try to reset the password on some users, not all, I get the following error.
    "Error setting password for '<span style="font-style: italic">User Display Name</span>' on LDAP://<span style="font-style: italic">full LDAP name of user</span>, E_ADS_OBJECT_UNBOUND".
    I was able to successfully reset the password with the AD Users and Computer MSC. I recently upgrade to Hyena 7.2 from 7.0 so I tried the same user account on another PC with 7.0. It worked fine from there.

    [This message has been edited by JasonCramsey (edited 04-07-2008).]

    [This message has been edited by JasonCramsey (edited 04-07-2008).]

  • #2
    Re: Error E_ADS_OBJECT_UNBOUND when setting password

    So far the only the only constant in the user accounts are they were created in 2005 and never used. I was able to re-enable the accounts but not set the password. A colleague had the same issue on an actively used account though.

    Comment


    • #3
      Re: Error E_ADS_OBJECT_UNBOUND when setting password

      What happens if you right-click on one of these users and choose Account Functions->Reset Password?

      Comment


      • #4
        Re: Error E_ADS_OBJECT_UNBOUND when setting password

        Same problem. Windows 2000 domain. We have two domain controllers in this site so I tried connecting to the other. No change.

        Comment


        • #5
          Re: Error E_ADS_OBJECT_UNBOUND when setting password

          This appears to be some limitation in your environment that is causing this error, as if it were a bug we would have a lot of users reporting this problem already (resetting passwords is a common function).

          I did a quick search on Google and this error is not very common, and even then usually due to newly created accounts, which does not appear to be the case here. Microsoft does not provide any documentation for this errors, or any errors for that matter.

          The function Hyena uses to set a password is real simple: Hyena binds to the AD object, gets the IADsUser interface, then calls the SetPassword method. It the SetPassword method that is returning this error.

          The only two things that can change are the path to the object and the flags used to bind to the object. The path should be something like LDAP://dns.dc.path/CN=userID,CN=Users,etc.

          If you instead see a Netbios name right after the LDAP://, then change the path to the domain under File->Manage Object View.

          Hyena v7.2 added some new binding flags that can be used for additional security but can cause all sort of issues if enabled inadvertently, naming AD SSL and signing and sealing. These options can be turned on using the Advanced Registry Settings as discussed in the Advanced section in the Help file.

          Let us know if you turn up anything.

          Thanks
          Kevin Stanush
          SystemTools Software Inc.

          Comment


          • #6
            Re: Error E_ADS_OBJECT_UNBOUND when setting password

            It was in fact the NetBIOS name after LDAP so I changed it to the DNS name. After I restarted Hyena I was able to reset the password on one of the effected accounts. Thank you for your assistance.

            Comment

            Working...
            X